Labfolder Service Interuptions

Incident Report for Labforward Cloud

Resolved

This incident has been resolved.
Posted Jul 20, 2023 - 14:43 CEST

Monitoring

We continue the monitor the system closely.
Posted Jul 20, 2023 - 12:11 CEST

Investigating

We are currently investigating this issue.
Posted Jul 20, 2023 - 11:39 CEST
This incident affected: Labfolder & Labregister.